RSS

Enabling Code Coverage on TFS Build Server Without VS Test Edition

13 Oct

Back in May 2009 I exchanged a number of emails with Buck Hodges regarding Code Coverage on my build server. Here’s my original blog: Oi Microsoft, this IS part of Development!. Basically, the upshot was if you don’t have Visual Studio 2008 Test Edition installed on your build server you will not be able to run Code Coverage as part of your automated builds.

Well, I’ve now managed it.
To be honest I’m not exactly sure how this happened! Inside my Default.TestRunConfig file I had my main (ASP.Net MVC) project enabled. Recently, I have added more projects to my solution and their respective \bin\debug\ dlls have been automatically added to the Code Coverage list of artifacts to instrument. I then noticed that Code Coverage results were appearing in the build for these new libraries. No coverage for my main project though. The final stage was to remove the Code Coverage reference to the main project and, instead, target the resultant dll.
I now have full unit testing and code coverage on my entire solution – a result that, apparently, can’t happen.
Advertisements
 
Leave a comment

Posted by on October 13, 2009 in Programming

 

Tags: , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: